HomeDocumentation > Developer's guide > Geronimo and Geronimo Eclipse Plugin System Requirements

This page details the system requirements for Geronimo and Geronimo Eclipse Plugin. These include various flavors of operating system(recommended and compatible), JDK versions/vendors, Database vendors/versions, memory requirements(for running and building).

Operating System

Recommended-R Compatible-C

Platform32-bit64-bit
   
   
   
   
   
   
   
   
   
   
   
   
   
   
   
   
   
   
   
   
   

JDK Version/Vendors

*Recommended-R Compatible-C

VendorVersionState*
   
   
   
   
   
   
   

Database Vendors/Versions

*Recommended-R Compatible-C

VendorVersionState*
   
   
   
   
   
   

Requirements for running and building Geronimo

Memory

Maven

Subversion

Requirements for running and building Geronimo Eclipse Plugin

Memory

Maven

Subversion